PO Import quite inconsistent

I’m trying to import POs but am finding quite a few inconsistencies.

  1. In Cetec ERP Scheduled is marked as Mandatory, but it doesn’t even appear in the dropdown choices on the import system
  2. Cetec ERP and the actual exported data examples don’t match formats. Terms, for example, are exported as reference numbers but defined in the example as a varchar like ‘NET30’
  3. Creation dates can’t seem to be read no matter what. I put them in in the appropriate format via excel or csv or whatever and all the line reading fails (Error Loading Row X). When I take them out, nothing is imported. So it is possible it is failing without even trying to read the dates when I don’t select the column and then another field’s formatting is causing problems - it is unclear. I doubt it though, I removed all but one defined set of necessary columns and it still failed. Interestingly, this same error isn’t triggered by other dates. So I tried changing the creation date to today (figuring back dating was the issue) but no dice.
  4. There is a field for vendor_external_key. Okay. I go to Vendor edit and there’s a field for Ext. Vendor ID. That seems to match nicely. But when I view the list of vendors and show External Key what I put in Ext. Vendor ID doesn’t show up. So I don’t actually know which field this is or where to input it in the vendor in a way that is relevant to the PO import.
  5. The necessary fields documentation is inconsistent. The import tool shows: Order Number, Vendor Key (external key of Vendor Record), Location. When I do that (adding in line number, part number, orig_qty and unit_cost) I get no errors, but nothing is imported. Cetec ERP adds the basic line details and terms, FOB, shipvia and scheduled. Interestingly, this other document requires remaining quantity and due date. Whatever the mix I do, no POs are imported. Perhaps it is the vendor key issues.

I’m obviously not at all averse to data imports. We did it for parts and vendors. The PO one just seems a bit, well, unhealthy.

Hi @jcox,

Thanks for the questions. Let us review the the PO import process, and see if we can clarify any of the issues here. We’ll get back to you about it as soon as we can.

@jcox Just to confirm, you’re using the data import tool under Admin > APIs & More > Data Import when attempting to import the POs, correct?



Engineering here.

Thank you for your feedback.

Some claification for you on this issue. If you are using Admin > APIs & More > Data Import tool that allows you to import directly from within Cetec then the documentation you are referring to isn’t meant for that.

As of right now, it is meant for Cetec to give customers a reference for how they should format their data if we are importing it for them.

We have internal software that this documentation maps to.

The goal for the future is to one day replace the import tool you are using with our internal software and have the documentation be used for both.

Apologies on the confusion.