Commit BOM / Update labor

After copying a BOM worksheet from another quote and then committing the BOM, it wiped out all the lines. Then when going to the labor estimate, tried to copy the labor from another part to edit it then update, it wiped all the labor just edited.

Hi Steve,

Can you elaborate a little bit for us. The first link seems to be a test that you’ve created, but doesn’t appear to be a clone or to have been cloned?

The second does look like it was cloned, but the part on the new quote is different that the part from the original.
Is the original part from the original order the part from which you tried to copy the labor?

The issue is happening when we clone a quote and / or copy a BOM worksheet into a new quote or the cloned quote. On these copies or clones it is not letting us copy the labor from an existing Prcpart; or rather it will copy the labor but, when we go to make some revisions in the labor build and then update, the data disappears.


We have tried several times to reproduce what you are describing (cloning a quote, subsequently copying a bom worksheet and committing to see if it wipes out lines; copying labor from another part and having it wipe all the labor).

We’re not seeing any behavior like that at all. Everything seems to be working fine, and we are testing on the same version you are using.

Maybe this is specific to your dataset… would you perhaps be able to re-create this problem using a fake BOM and a fake Quote in your own jst-gam system, and walk us through the exact steps, step by step, you are taking with those fake examples in order to reproduce this problem (possibly with screenshots and URLs).

Then, possibly we could clone your fake/example data set into a test environment and see if we could reproduce it with your data there.

Let us know if this is possible, appreciate it!

I’ve asked our quoting specialists to try again and it seems that the processes are working fine now. It may have been an isolated incident or they were doing something wrong. I also tried duplicating the issue and have no problems.

Sorry for wasting your time! Thank you for your support.

No problem Steven!
Definitely not wasting our time, we’re always happy to help.
Let us know if you run in to any other issues.