Date Code Format on Receiving Changes When Selecting PO Line

I’ve set a custom date code format (YYYYMMDD). When I go to Receiving and select a PO the date code appears correctly. However, as soon as I select a line item on the PO, the date code changes to a two-digit year and week number (e.g. 2145 currently). I’m guessing there is some setting or override occurring, but I’m unable to find the setting anywhere.

Can anyone help?

Hi, Adam,

Thanks for reaching out. Just to be sure I understand, are you saying that you are going to Warehouse > Receiving > Receive Parts and manually entering a date in the YYYYMMDD format into the Date Code field?

And then, when you make a selection in the PO Line field, what you typed into the Date Code field changes?

If I’m on the same page as you, then I followed those steps and what I’d entered in the Date Code field did not change when I made a selection in the PO Line field. But let me know if I’m off-base here!

Cetec ERP Support

Not exactly.

I have the Config Setting “Default Date Code On Receiving Screen” set to YYYMMDD. When I go to Warehouse > Receiving > Receive Parts the date code shows up correctly as YYYYMMDD. However, as soon as I select a PO Line the date code field changes to a two-digit year and week number format. If I remove the PO Line, it switches back to YYYYMMDD.

My only recourse (since I can’t figure out what’s going wrong) is to override the value to my desired format after selecting a PO line. However, this is quite error prone as you may imagine.

Strange. Just to check, is your web address amac.cetecerp.com? I have a couple of different records in our system attached to your profile.

Assuming that’s the correct URL, I went to Warehouse > Receiving > Receive Parts and then selected a PO line and here is what I saw:

The dates seem to be in that desired YYYYMMDD format. Is this not what you are wanting to see?

I did go to your config settings, and it looked like nothing was entered in terms of date format:

After you entered YYYYMMDD into those fields marked in red, did you click the orange Set button? That is what actually confirms your setting.

Take a look and see if that fixes the issue, and then let us know if you need more help!

Thanks,
Cetec ERP Support

We use two different accounts. One is for a customer of ours and one is actually ours. The one I’m talking about is sd.cetecerp.com.

The field in question is the Date Code field, not the date fields that you’ve highlighted.

Okay, I took a look at that screen on sd.cetecerp.com and I’m seeing what you’re seeing. I also tested this elsewhere and was able to reproduce the issue there as well.

Let me get this over to our engineering team. I’ll update you when we have more information.

Thanks for your patience,
Cetec ERP Support