Error adding line to quote

We’re getting the following error when attempting to add a line to a new quote.

We are getting the same error also.

@spilkington @Andy We’re not seeing those errors in test environments using your data. Can you walk us through step by step how you’re adding the line that’s resulting in the error?

I dont know about @spilkington , but when we try to add a line to a quote in which the part does not exist yet, it will throw that error

Please refer to the video link for a demo of the process.

Problem demo

We get the same error when trying to add that was as well.

@Andy @spilkington I think that’s the missing piece here, so in both cases these are new parts/boms being added to the quotes, not ones that already exist in the system?

That is correct.

Yes that is the case here too

Our engineers took a look here, and we have a fix in the works that should go out in the next week or so. In the meantime, as a workaround you should be able to create the parts first, and then add them to the quotes, and that should allow you to do so without error.

Not sure why it was working OK last week and then stopped. I hope it will be solved next week as this workaround will slow down our processes a bit.