getting an error "check create failed"

trying to enter a quote and getting an error “check create failed”
how do you clear this??

i wrote the problem incorrectly…trying to generate a new check and getting “check create failed”…how do you clear this…i am unable to write any checks in the system

Good Afternoon!

We apologize about the delay in response here, this seems to be something wrong for sure. Could you provide us with a link to a payment that you cannot write a check for? This would help us in narrowing down the possible problem points. Any payment would be helpful

Best Regards,

Thanks for getting back to me…………i need to get this resolved for end of year check run


The last check we wrote was from a voucher

seems like it went through ok

then we just tried to generate a check to pay utility bill…………asked to create next check……typed in who we were paying………hit create check………and got this

so not sure if it is something we did or something else

Good Morning JJ!

Okay thank you for that information. We are running through some tests on our internal server to see what may be going wrong. We will get back to you shortly with an update on the results of those tests.

Best Regards,

i hope you have this figured out…i need to run checks before year end

Good Morning JJ,

We have just heard from engineering that the fix for this was deployed this morning. We tested this in our internal server and we created a check successfully. Please could you test this out on your instance it should allow you to create a check from the check register directly.

Best Regards,

well it worked on the first check we wrote for the utilities check…than we vouchered and generated a check for those vouchered items…than from check register we tried to generate another check and got the error again

we are running out of time to write the rest of our checks …HELP!!!

well we did get the error noted above…than we logged out of system and went back in and error did not re-occur
so i think we are good ???

it is happening again…wrote a check (not from a voucher)…when i went to “create new check” …i got “check create failed” again

please advise

it looks like you can create the first check …but when you go to “create next check” that is where we are getting the “check create failed” error

so i know where the bug is…if you create a check from check register it will create just fine…than if you try to create next check from that screen you will get the “check create failed” error…however if you go back to the check register and create check from that screen…it will go through fine

you guys going to answer this issue??

Hi @jjclarizio Thanks for the continued troubleshooting to determine that the issue is happening when trying to create the next check from an existing check.

We’ll have to get with our engineering team to determine why that is. In the meantime you should be able to go back out to the check register and create checks from there, as long as you’re not getting errors there anymore.


We do have a fix for the “Create Next Check” button which should go out to you next week. In the meantime, as cetecerp13 stated you should still be able to create a check from the check register.

Apologies for the inconvenience here.