How to get check to print from "bill to" info instead of "ship to" info

I’m trying to issue some refund checks for customers that were created through credit memos. When I issue the check it is writing it to the “Ship To” name but I need it to be written to the “Bill To” name. How do I adjust this?

Hi Kali,

Can you walk us through the process you’re using when creating the refund/check, and possibly provide a link to the check you’re looking at?
Normally when you issue a refund by creating a credit memo and then issuing the check, the system should pull that customer’s Bill To address.

Thank you for pointing that out. I dug into it a little further and this particular one is not from a credit memo but an overpayment. If I provide a link does that give everyone on the forum access to it?

We’d be hapy to take a look for you.

It will not, as they don’t have a way to log in to your instance. But, if you want to be extra cautious, you could just share the part of the URL that comes after the .com, and we can find the right domain.

Ok here’s the link…

https://wadsworthdesign.cetecerp.com/checkregister/2778/edit_check

Thanks for sending that!

So, Looking at that check, what appears to be happening is that the “Pay to the order of” line on the check is using the customer name from the customer record, while the PDF of the check does have the correct Bill To address information in the address field to mail the check.

The customer record: https://wadsworthdesign.cetecerp.com/customer/457/view

This is what we would expect to see normally, and no matter where you create a check in the system it’s always going to reference that customer record for that data.

I’m a little confused on your explanation, but I think I understand what you’re saying and yes that is what’s currently happening. However, we need it changed. We have run into this problem before and had to ask to have it changed. We need the “Pay to the order of” line to pull from the Bill To and not the Ship To or else I can’t write refund checks to the customers. On the accounting side of things, that is the whole reason to have a bill to and a ship to.

@kali - On that customer record, the Customer “Name” itself matches that ShipTo Address Name, not the BillTo Address Name.

So, when you say “We need the “Pay to the order of” line to pull from the Bill To and not the Ship To or else I can’t write refund checks to the customers.” - just want to be clear, the “Pay to the order of” field does not currently pull from the BillTo Address Name, it pulls from the Customer Name on the customer record. In other words, if you changed that customer name on the top-level customer record, that would fix this check. (I realize you may not want to do that, but just wanted to clarify).

If you’d like, you could also customize your check PDF to utilize the BillTo Address Name for the “Pay to the order of” field. It looks like Wadsworth already has a custom check. If you are able to do that yourselves, wonderful. If not, please email “sales@cetecerp.com” with details on the request and we’ll provide you with a quote to make the customization. (It would be very quick, < 1 hr).

Thanks!

We tried to fix it and it gave us this error…

@kali - we will look into why you’re getting this error and get back to you ASAP! Thanks for your patience.

@kali

We’ve addressed the issue with uploading custom checks. Can you please try to upload again?

The upload works now, but specific to the problem of changing from the Customer Name to the Bill To name we can’t get it to work because we can’t find the name/variable for the type of unapplied cash that it is. We had it fixed in the past for the credit memo but we can’t figure it out as this type of refund.

I will need help getting this fixed and since the customer has been waiting for their refund for weeks, I will need it done sooner than later. Thank you.

Hi Kali:
It looks like this was done by refunding unapplied cash, not a credit memo. Confusion around that was making this hard to track on my end, though we should have picked up on that.

Anyway, we’ve edited the “pay_to” field to be what we believe to be the proper billto name behind the scenes.

Please let us know if it needs additional adjustment.

Thanks!

That seems to have worked. Thank you.

Ok looking into it, it is only fixed for that one customer. I have others with the same situation. Is there a way to do a more permanent fix like you guys did with the credit memos? Thanks.

Hi Kali,

I think the update we just released to you for that document will link the customer billto name through the Unapplied Cash object.

It looks like that did work properly for the initially provided check id.
Can you check a few others please and see if they are showing what you need them to now?

Thanks!

Awesome. Thank you.