Issues with RMA Processes for Receiving PO's and Rework Orders

We’ve noticed a few bugs with the RMA Screens after the release of 4.0.1, related with associated creating “Receiving PO’s” and “Rework Orders”.

in a previous post, I mention that the “Create Receiving PO” does not actually create a “Receiving PO”. It displays a Dialog box asking “Are you sure you want to create a PO for all lines with Return Qty?”, but when you click on the “OK” button, there is a “Green” Banner that says “Success: RMA updated” . But no receiving PO # is generated on this screen.

Also, I’m able to initially create rework order but…

  1. The rework order has been changed to a “Production order” whereas in the past, it was a “Sales work Order”
  2. When the rework order (ie. 5192.1) is closed, it is no longer associated with the RMA and the “rework to stock?” checkbox returns along with the “Create rework order” button.

Hi, Regis,

Thanks for letting us know. I was able to reproduce that “Create Receiving PO” issue, and will check on why that might be happening.

However, I’m having trouble reproducing the second issue you mentioned. When I click “Create Rework Order” from the RMA screen, it is creating a “Sales Work Order” for me (see image below).

When I complete and invoice that “Sales Work Order”, it’s still showing an association with the RMA:

Am I missing something? Can you give it another try and let me know if you are still running into that problem?

I think this is my mistake:

under RMA# 122 rework order 5192.1, work order screen, it shows up under “Production – Orders”. but when i check out the overview, it’s under "Sales – Orders"

Okay! Glad you got that issue figured out. Checking into issue #1.

Regis,

Just checking in: Are you still running into issues creating a receiving PO? Our engineering team was testing it and not able to reproduce the issue. But obviously what matters is whether or not it’s working on your end.

Just let us know and we’ll go from there,
Cetec ERP Support

i’m trying to do it on this RMA # (…/rma/123/edit) and it still doesn’t work…

Bummer. Okay, I’ve sent this back to engineering after testing it again in both our beta environment and your live environment.

Sorry about this. We really appreciate your patience!

Cetec ERP Support

Regis,

I have an update for you: There’s a fix for this coming late this week or early next week.

Right now, your config setting pquote_no_approval_required is set to 0 and is blocking this from creating a PO. If you set that config to 1, then this will work.

Let us know if that doesn’t work!

Cetec ERP Support

yes. Changing the “pquote_no_approval_required” parameter to “1” worked. It looks like the logic changed then between v3.11 and v4.0? Looking at the config settings, the parameter was last set to “0” back in 2018 …

I think you’re probably right about that. Looks like engineering is aware of the issue. Thanks for doing this research!