Possible PO Cutoff Bug

When I set PQuote_Approval_Anyone_If_Under_Value to 1000, I expected to give everybody the ability to approve quotes under 1000. Instead, when I next saw a Pquote for tens of thousands our Pquote approver had no approval option. I got rid of the setting and then he could actually approve quotes again.

@jcox Does that user have the PQuote Approval role? If they do, and it was still not giving them the option to approve, then can you let us know which user it is so we can investigate further?
Thanks!

The user was icox. He got permissions back when I turned the flag off.

@jcox

It looks like in the Security by Roles page (Admin → Users → Security By Role) PQuote Approval is blocked by the role Manager which user icox has and is why they cannot approve PQuotes. The specific name is ‘Can Approve PQuotes - Block’

You will either need to remove the role Manager as a block here or switch up user icox’s roles to resolve this.

Thanks!

thanks. Done. We’ll see if he can approve with the flag back on.